Legend:
- KOLAP: OLAP
- KINFRA: Core
- KUI: User interfaces (Workbench, GAdmin, Reveal, KAgent)
- KGEO: Geospatial and Graph
- KECO: APIs and SDKs
- KDOC: Documentation
- KDEVOPS: KAgent and Kinetica Cloud
7.2.3.8
- The previous 7.2.3 release was 7.2.3.7.
- It is recommended to use the latest KAgent version (7.2.3.7) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.11
- Apache HTTP Server (httpd) version 2.4.66
- Apache Tomcat version 9.0.115
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KGEO-1384 | Added label entity counts to the show/graph response. The info map of the response has the 'labeljson' key where its value is a JSON string that is captured by the Workbench UI and displayed. The same info is also available as part of create|alter/graph response in case schema generation (default on) is requested. | Task | |
| KINFRA-4138 | Addressed an issue where very large responses in JSON encoding could result in a crash. | 7.2.3.6 | Bug |
| KINFRA-4140 | Changed Kafka timeout-related events to log at a WARN level instead of ERROR. | Task | |
| KINFRA-4142 | Addressed an issue where dropping a table with a CAGRA or HNSW column index would leave a dangling reference in the persist tier manager. | 7.2.3.7 | Bug |
| KINFRA-4144 | Addressed an issue where rebalancing a cluster containing tables with certain large data types would result in crashes or data loss. | 7.2.2.0 | Bug |
| KOLAP-5346 | Improved performance when calculating ROLLUP aggregates. | Task | |
| KOLAP-5616 | Added support for uploading files from nested directories via JDBC. | Task | |
| KOLAP-5625 | Addressed an issue where renaming a schema containing periodically executing SQL procedures would report errors. | 7.2.3.5 | Bug |
| KOLAP-5652 | Improved performance of various geospatial operations including ST_INTERSECTS, ST_CONTAINS and similar by skipping chunks when possible. | Task | |
| KOLAP-5654 | Addressed an issue where some array functions were incorrectly using 0-based instead of 1-based indexing. | Task | |
| KOLAP-5664 | Addressed an issue where doing a UNION ALL with arrays of different sizes would sometimes fail. | 7.2.3.5 | Bug |
| KOLAP-5666 | Addressed an issue where the /execute/sql endpoint could return an incorrect total_number_of_records when executing a SQL query with both an offset and a limit. | 7.2.3.6 | Bug |
| KOLAP-5669 | Improved performance in aggregate (group by) processing for dictionary encoded columns. | Task | |
| KOLAP-5690 | Added support for the "rest" credential type for interacting with Iceberg catalogs. | Task | |
| KOLAP-5693 | Improved performance for aggregate (group by) processing when there is a limit specified. | Task | |
| KOLAP-5694 | Added support for the ALTER STREAM SQL statement. | Task | |
| KOLAP-5695 | Added support for the DESCRIBE RESOURCE GROUP SQL statement | Task | |
| KOLAP-5696 | Addressed an issue where sorting a projection via the RAND() function was only outputting a subset of results. | master | Bug |
| KOLAP-5703 | Addressed an issue where aggregate (group by) processing could be using more memory than needed. | Task | |
| KOLAP-5706 | Addressed an issue where the PI() function was not recognized in some contexts. | 7.2.3.6 | Bug |
| KOLAP-5709 | Addressed an issue where aggregate processing returned an error when using an alias with the same name as another column in the table. | 7.2.3.6 | Bug |
| KOLAP-5711 | Addressed an issue where an error was returned when trying to perform a "union all" operation on top of a semi-join. | 7.2.3.6 | Bug |
| KOLAP-5712 | Addressed an issue where a null group could be returned in some aggregate queries, even though null values should have been filtered out. | 7.2.2.29, 7.2.3.8 | Bug |
| KOLAP-5714 | Addressed an issue where converting very small floating-point numbers to strings would return 0. | 7.2.3.7 | Bug |
| KOLAP-5715 | Addressed an issue where some external tables would fail to be created when the SUBSCRIBE=TRUE option was specified. | 7.2.3.7 | Bug |
| KOLAP-5718 | Addressed an issue where some materialized views would be synced to workers multiple times, resulting in erroneous errors in the log. | 7.2.3.0 | Bug |
| KOLAP-5720 | Addressed an issue where a CASE expression could return NULL instead of the correct indexed value when the default expression is a column that is NULL. | 7.2.3.8 | Bug |
| KUI-3021 | Added geolocation coordinate overlay support in Reveal maps to indicate the current mouse position. | Task | |
| KUI-3022 | Added geolocation coordinate overlay support in Workbench maps to indicate the current mouse position. | Task | |
| KUI-3023 | Added a new Markdown block within Workbench workbooks. | Task | |
| KUI-3024 | Enhanced Workbench graph visualization to automatically render the graph after a CREATE GRAPH query is executed in the SQL block. Additionally, selecting tables in graph configuration will automatically populate suggested column names for nodes and edges. | Task | |
| KUI-3027 | Added per-user rate-limiting to Workbench server endpoints to prevent overload and potential abuse. | Task | |
| KUI-3028 | Added graph visualization to Workbench to display label count statistics from graph endpoint responses. | Task | |
| KUI-3029 | Redesigned table export in Workbench to include a tabbed layout, data sink support, batch size configuration, and other expanded export options. | Task |
7.2.2.30
- The previous 7.2.2 release was 7.2.2.29.
- It is recommended to use the latest KAgent version (7.2.2.25) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.2.17
- Apache HTTP Server (httpd) version 2.4.66
- Apache Tomcat version 9.0.115
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KOLAP-5591 | Addressed an issue resulting in various errors which sometimes included a segfault, when processing window functions on a table that was the result of an Outer Join. | 7.2.3.4 | Bug |
| KOLAP-5728 | Addressed an issue where the SQL Planner could run out of memory over time. | 7.2.2.0, 7.2.3.0 | Bug |
7.2.3.9
- The previous 7.2.3 release was 7.2.3.8.
- It is recommended to use the latest KAgent version (7.2.3.7) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.14
- Apache HTTP Server (httpd) version 2.4.66
- Apache Tomcat version 9.0.115
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KECO-2513 | Added support for higher precision decimal columns within Python UDFs. | Task | |
| KINFRA-4137 | Added support for backing up and restoring resource groups. | Task | |
| KINFRA-4145 | Addressed an issue where multiple calls to /alter/table could run simultaneously for the same table and conflict, causing failures. | 7.2.3.0 | Bug |
| KINFRA-4148 | Updated the error message for /alter/table when attempting to set a tiering strategy on join tables. | 7.2.3.9 | Bug |
| KINFRA-4154 | Addressed an issue where resource group data tracking would report incorrect usage after adding a column to a table with an existing attribute index. | 7.2.3.8, 7.2.2.30 | Bug |
| KOLAP-4912 | Added support for SQL Intervals with fractional numbers; e.g. SELECT INTERVAL '2.5 MINUTES'. | 7.2.0.9 | Bug |
| KOLAP-5554 | Added a SQL command (REFRESH VIEW ALL) to refresh all Materialized Views, regardless of load policy. | Task | |
| KOLAP-5647 | Reduced memory utilization in Group By processing for large tables. | Task | |
| KOLAP-5689 | Added support for vector, array, geometry, JSON and bytes types to be returned from arg_min() and arg_max() aggregate functions. | Task | |
| KOLAP-5716 | Improved performance for geospatial operations on geometries containing multipolygons where only a small percentage of the outer envelope is covered. | Task | |
| KOLAP-5719 | Improved the handling of timeouts from Kafka servers. | Task | |
| KOLAP-5726 | Added support for more file-based credentials to use files in KIFS. | Task | |
| KOLAP-5728 | Addressed an issue where the SQL Planner memory usage would increase over time. | 7.2.2.0, 7.2.3.0 | Bug |
| KOLAP-5729 | Addressed an issue leading to a crash when a string parameter was passed to certain geospatial functions expecting a geometry. | 7.2.2.27, 7.2.3.8 | Bug |
| KOLAP-5731 | Addressed an issue where the Postgres Wireline Copy Protocol would fail with some queries. | 7.2.3.8 | Bug |
| KOLAP-5735 | Added support for specifying a limit using a query parameter. Addressed an issue where DECIMAL_DIGITS were not being returned in JDBC Metadata. |
7.2.3.8 | Bug |
| KOLAP-5736 | Addressed an issue where incorrect results were being returned in some instances for certain repeated queries on materialized views. | 7.2.3.8 | Bug |
| KOLAP-5742 | Addressed an issue with case-sensitivity of UUID comparison checks. | 7.2.3.6 | Bug |
| KOLAP-5747 | Addressed an issue with incorrect results when comparing decimal values with different scales. | 7.2.3.8 | Bug |
| KUI-3030 | Improved efficiency of Workbench user login onboarding and active session checks. | Task | |
| KUI-3036 | Improved Workbench import from KIFS by automatically extracting the schema name from the KIFS filename when possible. | Task | |
| KUI-3037 | Fixed parsing of execute function queries in Workbench to correctly display status for all formatting cases. | Task |
7.2.3.10
- The previous 7.2.3 release was 7.2.3.9.
- It is recommended to use the latest KAgent version (7.2.3.7) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.14
- Apache HTTP Server (httpd) version 2.4.66
- Apache Tomcat version 9.0.115
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KINFRA-4158 | Addressed an issue where updating values in a geometry column could lead to a crash. | 7.2.3.9 | Bug |
| KINFRA-4160 | Addressed an issue where rebalancing the cluster could cause one or more worker ranks to deadlock. | 7.2.3.9 | Bug |
| KOLAP-5203 | Addressed an issue where the APPROX_COUNT_DISTINCT aggregate function could return incorrect results when the cardinality is very large (>100 million). | 7.2.2.6 | Bug |
| KOLAP-5215 | Addressed an issue where the UNNEST_JSON_ARRAY table function reported an error when the input was based on the results of a JSON_QUERY function. | 7.2.2.7 | Bug |
| KOLAP-5704 | Added the ST_CLUSTERDBSCAN window function, compatible with the PostGIS implementation, to be able to perform DBSCAN clustering. Also added a similar STXY_CLUSTERDBSCAN function which uses x, y coordinates in place of the geometry parameter. | Task | |
| KOLAP-5732 | Improved the clearing of intermediate tables in a Materialized View processing in order to reduce memory usage. | Task | |
| KOLAP-5741 | Addressed an issue where window functions were only working with column aliases and not the original column names. | 7.2.3.8 | Bug |
| KOLAP-5745 | Modified the behavior of the scoped hint KI_HINT_MATERIALIZE to always add a materialization step when specified, even if the step would have already been considered materialized. | Task | |
| KOLAP-5750 | Improved performance of semi-joins when the semi-join is then used in subsequent join operations. | Task | |
| KOLAP-5751 | Addressed an issue parsing large integer constants with more than 19 digits within certain expressions. | 7.2.3.8 | Bug |
| KOLAP-5754 | Added NEXT_AFTER and NEXT_BEFORE functions. Addressed an issue with some geospatial distance calculations treating less-than (<) the same as less-than-or-equal (<=). |
7.2.3.8 | Bug |
7.2.3.11
- The previous 7.2.3 release was 7.2.3.10.
- It is recommended to use the latest KAgent version (7.2.3.7) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.15
- Apache HTTP Server (httpd) version 2.4.66
- Apache Tomcat version 9.0.115
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KGEO-1387 | Addressed an issue where long-running graph queries could fail to cancel properly. | 7.2.3.10 | Bug |
| KGEO-1388 | Added a new 'match_route_detour' solver to /match/graph to find detour penalties over a scheduled route for pit-stops within a reachability threshold. | Task | |
| KGEO-1389 | Addressed an issue where GPU-accelerated stippled (dashed) line rendering could crash in certain cases. | 7.2.2.29, 7.2.3.8 | Bug |
| KGEO-1390 | Added table output for the new 'match_route_detour' solver. | Task | |
| KINFRA-4152 | Addressed an issue where table type metadata was not being cleared when no longer referenced by any tables. | Task | |
| KINFRA-4161 | Addressed an issue where issuing a solo job while kafka subscriptions were active could lead to a worker process crash. | 7.2.2.29, 7.2.3.9 | Bug |
| KINFRA-4165 | Addressed an issue where spurious warnings would be logged when geospatial indexes are evicted from memory. | 7.2.3.10 | Bug |
| KINFRA-4166 | Addressed an issue where memory reporting functions were returning misleading results when run inside of containers. | 7.2.3.10 | Bug |
| KINFRA-4167 | Addressed an issue where the failed_notifications_table for a stream would get dropped if the table being monitored is altered | 7.2.3.10 | Bug |
| KOLAP-5648 | Added support for the Puffin file format (v3) for handling deletes in Iceberg datasets. | Task | |
| KOLAP-5657 | Improved performance for calculating COUNT DISTINCT for long strings. | Task | |
| KOLAP-5721 | Addressed an issue where the LIKE operator was not recognized in some SQL contexts. | 7.2.3.8 | Bug |
| KOLAP-5756 | Improved performance of null handling in FIRST, LAST, LAG and LEAD window functions. Improved performance of when multiple window functions within the same query have the same PARTITION BY/ORDER BY parameters. Improved performance of MIN, MAX, STDDEV and PRODUCT window functions with range framing. | Task | |
| KOLAP-5760 | Added support for the TIMEZONE function to be able to convert datetime/timestamp values to a specific time zone. E.g., TIMEZONE('Pacific/Auckland', NOW()) | Task |
7.2.3.12
- The previous 7.2.3 release was 7.2.3.11.
- It is recommended to use the latest KAgent version (7.2.3.7) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.16
- Apache HTTP Server (httpd) version 2.4.66
- Apache Tomcat version 9.0.116
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KGEO-1392 | Added a new 'greedy_traversal' option for /query/graph in order to ensure consistent results regardless of table input order for multiple edge multi-source undirected graph use cases. | Task | |
| KGEO-1394 | Added a new '/get/graph/entities' endpoint to be able to retrieve data for use by third party packages such as graph layout visualization libraries. | Task | |
| KGEO-1395 | Modified the '/show/graph' endpoint (used by the SQL 'DESCRIBE GRAPH' command) to be able to show the ontology via the internal option 'export_graph_schema'. For fast ontologies, added another new internal option 'schema_full_search' with a default value of 'false'. Set it to 'true' to generate an accurate ontology for use cases where the same edge labels might be connecting different node label tuples. | Task | |
| KGEO-1397 | Addressed an issue with incorrect edge node output order in simple adjacency tree non-cypher queries. | 7.2.3.11 | Bug |
| KINFRA-4153 | Adds backup/restore support for User Defined Functions | Task | |
| KINFRA-4156 | Adds backup/restore support for Python Function Environments | Task | |
| KINFRA-4170 | Addressed an issue where HNSW vector indexes were not reloaded correctly on a restart, leading to a crash. | 7.2.3.11 | Bug |
| KINFRA-4176 | Addressed an issue where WAL replay could crash on a table with an x/y geospatial index. | 7.2.3.11 | Bug |
| KINFRA-4178 | Addressed an issue where the table repair logic could be short-circuited by corrupt column files. | 7.2.3.11 | Bug |
| KINFRA-4180 | Added a new config option 'wal.auto_truncate_corrupt_tables' to control background repair of corrupt tables. | Task | |
| KINFRA-4182 | Added logic to automatically mark chunks as corrupt if they fail to successfully read from persist. | Task | |
| KOLAP-4379 | Improved performance for window functions on string columns that don't rely on the actual string values (such as FIRST_VALUE, LAST_VALUE, LAG, and LEAD). | Task | |
| KOLAP-5361 | Addressed an issue where unions combining columns of TIME and DATE and DATETIME columns were failing due to missing implicit casts. | 7.2.2.15 | Bug |
| KOLAP-5441 | Added support for the 'compression_codec' option to more endpoints. | Task | |
| KOLAP-5650 | Improved performance for some group-by operations by avoiding sorting when not needed. | Task | |
| KOLAP-5717 | Improved performance for queries involving 'or' operators in conjunction with geospatial functions. | Task | |
| KOLAP-5746 | Improved performance for parsing and processing very long query expressions. | Task | |
| KOLAP-5748 | Addressed an issue where the UNNEST_JSON_ARRAY function could return an error when used in certain complex queries. | 7.2.3.9 | Bug |
| KOLAP-5759 | Improved performance when processing semi-joins in certain types of queries. | Task | |
| KOLAP-5761 | Addressed an issue where issuing a CREATE OR REPLACE on a table with a geospatial index would return an error if the table existed prior to the call. | 7.2.3.8 | Bug |
| KOLAP-5764 | Addressed an issue where certain complex joins (including geospatial joins) could lead to a crash if data was being concurrently ingested into the base tables. | 7.2.3.10 | Bug |
| KOLAP-5766 | Improved performance for merging intermediate results of large aggregations. | Task | |
| KOLAP-5770 | Improved performance of null handling in SUM, MIN and MAX window functions. |
Task | |
| KOLAP-5771 | Improved performance of window functions with range specifications, including the default range. | Task | |
| KOLAP-5773 | Added support for using string, json or geometry columns within a group-by 'having' clause. | 7.2.3.10 | Bug |
| KOLAP-5774 | Addressed an issue where casting from a string to a ULONG could lose precision. | 7.2.3.10 | Bug |
| KOLAP-5775 | Addressed an issue with semi-join and anti-join queries where the left or right side of the join contains a cross-joined set (multiple independent tables joined without a predicate). Affected queries could produce duplicate rows, missing rows, or errors such as columns being reported as removed by the semi-join when they should have been visible. This could occur when SQL subqueries or views used as inputs to IN, EXISTS, or NOT EXISTS clauses involved cross-product relationships between their member tables. | 7.2.3.10 | Bug |
| KOLAP-5776 | Addressed an issue where the SQL Planner would return a "ClassCast exception" error when processing queries involving certain CASE expressions. | 7.2.3.11 | Bug |
| KOLAP-5777 | Addressed an issue leading to a crash or error in certain cases when doing a group-by with a having clause that containing the ISNULL function. | 7.2.3.11 | Bug |
| KOLAP-5778 | Added a 'mode' option to the ST_TRACK_DWITHIN table function. The options are 'dwithin' (the default) and 'buffer_intersects'. | Task | |
| KOLAP-5783 | Added support for the EXCLUDE clause in window functions, including CURRENT ROW, TIES and GROUP options. | Task | |
| KOLAP-5785 | Added support for the /*+ KI_HINT_DELTA_QUERY */ scoped hint, enabling subqueries to return delta results. | Task | |
| KOLAP-5788 | Improved performance of window functions for single-rank clusters. | master | Bug |
| KOLAP-5789 | Improved performance of window functions by avoiding a reshard when the PARTITION BY clause matches a join key that is equated to a shard key in the input join. | Task | |
| KOLAP-5790 | Improved performance for queries with multiple window functions with different PARTITION clauses. | Task | |
| KOLAP-5792 | Improved performance of window functions which share a common set of PARTITION keys by eliminating redundant resharding steps. | Task | |
| KOLAP-5797 | Added support for the AT TIME ZONE 'tz_name' clause for time zone–aware timestamp conversions. | Task | |
| KOLAP-5802 | Improved performance for queries that involve similar sub-operators. | Task | |
| KOLAP-5803 | Addressed an issue where an expression looking for a ULONG value in an IN-list would return an error. | 7.2.3.11 | Bug |
| KOLAP-5806 | Addressed an issue where certain long, complex expressions involving many column could lead to a crash. | 7.2.3.12 | Bug |
| KOLAP-5808 | Addressed an issue where foreign key indexes were not rebuilt in some cases after a database restart when the config parameter 'build_pk_index_on_start' was set to 'on_demand'. | 7.2.3.12 | Bug |
| KOLAP-5816 | Added support for specifying JOIN clauses within the FROM clause of DELETE statements. | Task | |
| KOLAP-5817 | Addressed an issue where using a materialized view within a subsequent query could crash if the materialized view was not yet fully constructed. | 7.2.2.29, 7.2.3.12 | Bug |
| KOLAP-5819 | Addressed an issue where date strings would not be accepted when inserting new records into a TIMESTAMP column. | 7.2.3.11 | Bug |
| KUI-3039 | Addressed an issue where Reveal slice views failed to load in slice embed mode. | 7.2.3.11 | Bug |
7.2.3.13
- The previous 7.2.3 release was 7.2.3.12.
- It is recommended to use the latest KAgent version (7.2.3.13) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.17
- Apache HTTP Server (httpd) version 2.4.66
- Apache Tomcat version 9.0.117
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KGEO-1396 | Added an internal option 'frontier_limit' for PGQ/Cypher-based queries to eliminate possible bottlenecks in BFS traversals at each hop. By default there is no limit. | Task | |
| KGEO-1397 | Addressed an issue with incorrect edge node output order in simple adjacency tree non-cypher queries. | 7.2.3.11 | Bug |
| KGEO-1398 | Implemented a new architecture for hop based constraint checks to attain asymptotic improvement that scales with graph size. Prior to this improvement hop-based constraints spent most of their time in insert_sorted (O(N²) build) and secondarily in binary_search (O(log N) per edge visit which is cache-unfriendly on a big sorted vector. Switched to a hash-set based approach to eliminate those costly steps. | Task | |
| KINFRA-4186 | Improved performance of streaming reads from S3 and GCS. | Task | |
| KINFRA-4187 | Added a new config option 'wal.clear_entries_immediately' to extend the lifetime of WAL entries to allow slower filesystem writes to complete without requiring an fsync. | Task | |
| KINFRA-4188 | Added a /check/table endpoint to scan for table errors. | Task | |
| KINFRA-4195 | Added virtual addressing configuration option (azure_use_virtual_addression) for Azure data sources. | Task | |
| KINFRA-4196 | Added validity check when a remote store returns HTTP 412 in case the operation actually succeeded. | Task | |
| KINFRA-4198 | Addressed an issue where a multihead insert into a replicated table could hang if received during cluster shutdown. | 7.2.3.12 | Bug |
| KINFRA-4203 | Updated repair logic to scan for, but not mutate, corrupt files when conf.wal.auto_truncate_corrupt_tables=false. | Task | |
| KINFRA-4205 | Addressed an issue where resharded inserts from Kafka which failed to insert would drop the records with a warning instead of retrying. | 7.2.3.12 | Bug |
| KOLAP-4892 | Improved performance for update affecting shard key columns by forwarding records directly to the destination rank. | Task | |
| KOLAP-5468 | Improved performance for copying data from one table to another with an ORDER BY and LIMIT. | Task | |
| KOLAP-5624 | Improved performance for group-by on string columns when a limit is specified. | Task | |
| KOLAP-5801 | Improved performance for group-by for large tables. | Task | |
| KOLAP-5805 | Improved performance for some complex SQL queries where the column order is specified in a different order in various sub-queries. | Task | |
| KOLAP-5807 | Added support for the standard QUALIFY clause in SQL to filter results of window functions. | Task | |
| KOLAP-5820 | Addressed an issue where the SQL Planner would return an 'Unexpected Planner Error' when attempting to parse certain correlated sub-queries. | 7.2.3.11 | Bug |
| KOLAP-5823 | Improved performance for operations on dictionary-encoded columns. | Task | |
| KOLAP-5824 | Addressed an issue where an error like: "Index 6 out of bounds for length 5" would be returned for some MERGE INTO queries involving sub-queries. | 7.2.3.12 | Bug |
| KOLAP-5825 | Improved performance by scheduling host-only unary filters after GPU-accelerated filters. | Task | |
| KOLAP-5827 | Addressed an issue where performing an UPDATE could sometimes return the error "Target row has no matching source row to update" on clusters with one worker rank. | 7.2.3.12 | Bug |
| KOLAP-5835 | Impoved performance for calculating COUNT DISTINCT. | Task | |
| KOLAP-5838 | Addressed an issue where calling /alter/table to add a partition could hang in some cases. | 7.2.3.12 | Bug |
| KOLAP-5840 | Addressed an issue where ST_ENVDWITHIN could return incorrect results in some cases. | 7.2.3.12 | Bug |
| KOLAP-5841 | Added support for the CHECK TABLE SQL statement. | Task | |
| KOLAP-5846 | Addressed an issue where all-false conditions to a DELETE would return an error, rather than simply deleting 0 rows. | 7.2.3.2 | Bug |
| KOLAP-5847 | Addressed an issue where the KISQL prompt did not show the current user, when the user was switched in the middle of a session. | 7.2.3.0 | Bug |
| KOLAP-5848 | Addressed an issue where the INVOKING_USER() function would return the impersonated user rather than the invoking user. | 7.2.3.0 | Bug |
| KOLAP-5849 | Added support for OAUTH authentication via the PostgreSQL Wireline Protocol. | Task | |
| KOLAP-5850 | Addressed an issue where the error "No Field with this name" was returned when attempting to use an aggregate function on a join table with an aliased column and using the alias for the aggregate function parameter. | 7.2.3.0 | Bug |
| KOLAP-5852 | Addressed an issue where an error was returned when attempting to update a TIMESTAMP column using the MERGE INTO command. | 7.2.3.12 | Bug |
| KOLAP-5856 | Addressed an issue leading to jobs hanging when processing queries with very large IN lists combined with certain other operators. | 7.2.3.13 | Bug |
| KOLAP-5859 | Improved performance for loading data into a partitioned table. | Task | |
| KOLAP-5861 | Addressed an issue where copying ULONG data using JDBC ingest from a remote query would fail. | 7.2.3.0 | Bug |
| KOLAP-5862 | Addressed an issue where the AT TIME ZONE clause would not be recognized when it was inside parentheses. | 7.2.3.12 | Bug |
| KOLAP-5864 | Improved performance for geo-joins with multiple st_dwithin (and similar) clauses by first calculating all of the intersects pre-filters. | Task | |
| KOLAP-5865 | Improved performance for sorting on dictionary-encoded column data by adding support for histogram-based sorting. | Task | |
| KOLAP-5867 | Addressed an issue leading to a crash when parsing very large filter expression involving many small OR expressions combined with AND and containing many similar clauses. | 7.2.3.12 | Bug |
| KOLAP-5871 | Improved performance for GROUP BY with LIMIT where large fixed or varying strings are involved. | Task | |
| KOLAP-5874 | Improved performance by converting more queries to use semi-joins and anti-joins when possible. | Task | |
| KOLAP-5880 | Improved performance for certain joins by using foreign keys when they are present. | Task | |
| KOLAP-5881 | Improved performance for joins involving equality of wide columns, such as unrestricted strings or geometries. | Task | |
| KOLAP-5890 | Addressed an issue where queries that were sorting the results based on vector functions, such as L1_DISTANCE, would not handle NULL value properly. | 7.2.3.13 | Bug |
| KOLAP-5893 | Addressed an issue with incorrect results with deletes involving correlated subqueries. | 7.2.3.13 | Bug |
7.2.3.14
- The previous 7.2.3 release was 7.2.3.13.
- It is recommended to use the latest KAgent version (7.2.3.14) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.19
- Apache HTTP Server (httpd) version 2.4.67
- Apache Tomcat version 9.0.118
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KDEVOPS-3079 | Upgraded Httpd to 2.4.67. | Task | |
| KDEVOPS-3082 | Upgraded Apache Tomcat to 9.0.118. | Task | |
| KDEVOPS-3083 | Updated the Java dependency to version 17 (from 11). | Task | |
| KGEO-1399 | Added support for the ST_WRAPX and ST_SHIFTLONGITUDE geospatial functions. | Task | |
| KGEO-1401 | Addressed an issue where classbreak track rendering could render incorrect results when the track crosses the date line. | 7.2.3.13 | Bug |
| KINFRA-4204 | Addressed an issue where restoring objects that had dependencies would not report an error that they were not successfully restored. | 7.2.3.12 | Bug |
| KINFRA-4208 | Added an option 'restore_subscriptions' for overriding the default behavior when restoring subscriptions. | Task | |
| KINFRA-4217 | Addressed an issue where the database could crash when querying metadata on a delta table base materialized view while the view was refreshing. | 7.2.3.13 | Bug |
| KOLAP-5810 | Improved performance for aggregate functions on unrestricted-length strings. | Task | |
| KOLAP-5830 | Improved performance for some window functions with empty OVER clauses. | Task | |
| KOLAP-5873 | Added support for PARTITION BY in CREATE MATERIALIZED VIEW statements. | Task | |
| KOLAP-5875 | Added support for partition options in /aggregate/groupby and /create/union endpoints. | Task | |
| KOLAP-5888 | Added support for accelerating semi-joins and anti-joins using primary keys. | Task | |
| KOLAP-5897 | Addressed an issue with aggregates when certain ranks or chunks had zero results leading to the error: "one response is hashed and the other is sorted". | 7.2.3.12 | Bug |
| KOLAP-5911 | Improved performance for queries when intermediate joins produce zero results. | Task | |
| KOLAP-5918 | Addressed an issue where the error "Cannot add expression of different type to set" would be returned for queries where the type of TIMESTAMPDIFF was inferred incorrectly. | 7.2.3.13 | Bug |
| KOLAP-5919 | Added support for empty OVER clause in window functions (note that this can be quite expensive for large tables). | Task | |
| KOLAP-5926 | Improved performance for credential checking when authorization is enabled. | Task | |
| KOLAP-5928 | Added the SQL command: VERIFY BACKUP. | Task | |
| KOLAP-5933 | Addressed an issue where sorting float or double columns that included NaN values could return errors in certain cases. | 7.2.3.13 | Bug |
| KOLAP-5936 | Addressed an issue where ingesting data from an external Sybase database would fail when attempting to partition on date columns. | 7.2.3.13 | Bug |
| KOLAP-5943 | Addressed an issue where updating a primary key column with a DECIMAL value would return an error. | 7.2.3.13, 7.2.3.14 | Bug |
| KOLAP-5944 | Addressed an issue resulting in an error when using the CURRENT_USER() function in some contexts. | 7.2.3.13 | Bug |
| KUI-3046 | Added support in Reveal to allow users to specify credentials to use when sharing/embedding slices. | Task | |
| KUI-3051 | Added support in the Reveal map slice to allow users to search for locations by lat/lon. | Task |
7.2.3.15
- The previous 7.2.3 release was 7.2.3.14.
- It is recommended to use the latest KAgent version (7.2.3.14) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.19
- Apache HTTP Server (httpd) version 2.4.67
- Apache Tomcat version 9.0.118
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KDEVOPS-3077 | Added a new release package for RHEL9/x86 which includes openssl libraries instead of using the host provided library. | Task |
7.2.3.16
- The previous 7.2.3 release was 7.2.3.15.
- It is recommended to use the latest KAgent version (7.2.3.14) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.19
- Apache HTTP Server (httpd) version 2.4.67
- Apache Tomcat version 9.0.118
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KOLAP-5963 | Addressed a race condition resulting in operations on particular tables getting stuck when background chunk deletion happens to occur at the same time as certain aggregate queries. | 7.2.3.13 | Bug |
7.2.3.17
- The previous 7.2.3 release was 7.2.3.16.
- It is recommended to use the latest KAgent version (7.2.3.14) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.19
- Apache HTTP Server (httpd) version 2.4.68
- Apache Tomcat version 9.0.118
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KDEVOPS-3087 | Updated httpd to 2.4.68. | Task |
7.2.3.18
- The previous 7.2.3 release was 7.2.3.17.
- It is recommended to use the latest KAgent version (7.2.3.18) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.20
- Apache HTTP Server (httpd) version 2.4.68
- Apache Tomcat version 9.0.119
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KDEVOPS-3090 | Updated Log4j in the SQL planner to 2.25.4. | Task | |
| KDEVOPS-3095 | Updated Apache Tomcat to 9.0.119. | Task | |
| KINFRA-4216 | Updated HA DR replay to merge requests in time order. | Task | |
| KINFRA-4222 | Added support for backing up and restoring KiFS directories. | Task | |
| KINFRA-4226 | Addressed an issue where peak_usage metric values were too high on insert-like queries. | 7.2.3.14 | Bug |
| KINFRA-4227 | Addressed an issue affecting cloud storage file subscriptions where files written within the same one-second window as the subscription's high-water mark could be permanently skipped during polling, causing occasional missed updates. | 7.2.3.14 | Bug |
| KINFRA-4231 | Addressed an issue where loading files from Azure could fail or load no data when the target folder contains a zero-length folder-marker blob. | 7.2.3.13 | Bug |
| KINFRA-4233 | Addressed an issue where permissions from non-restored objects were being applied which could inadvertently override existing permissions. Added the option 'restore_all_permissions' to explicitly apply all permissions from the backup instead of (by default) scoping to the restored objects only. | 7.2.3.17 | Bug |
| KINFRA-4243 | Addressed an issue where a LOAD INTO statement could finish processing but never complete the query. | 7.2.3.17 | Bug |
| KINFRA-4250 | Addressed an issue where the cluster processes could crash while shutting down | 7.2.3.17 | Bug |
| KOLAP-5228 | Added a "transformations" option in /insert/records to transform input data to table columns using expressions. | Task | |
| KOLAP-5328 | Added a new SIZE_PRETTY() function to output memory sizes in a human-readable format with memory units. | Task | |
| KOLAP-5734 | Modified the behavior of Materialized Views, Logical Views and SQL Stored Procedures such that they are now invalidated by default when a dependent table or view is dropped. This is now the default if CASCADE is not specified. Previously, CASCADE was the default. To keep previous behavior, add CASCADE to DROP statements. | Task | |
| KOLAP-5781 | Added support for default column values. | Task | |
| KOLAP-5894 | Improved performance for copying data from one table to another. | Task | |
| KOLAP-5900 | Improved performance for performing an anti-join with nullable columns. | Task | |
| KOLAP-5916 | Addressed an issue where last_refresh_time was not being updated for SQL Procedures when executed periodically. | 7.2.3.13 | Bug |
| KOLAP-5917 | Improved performance for inserting into partitioned tables. | Task | |
| KOLAP-5927 | Added a new 'update_with_user' flag for columns to be updated with the name of the user making any updates. Modified the 'update_with_now' flag to only update with NOW() when no other value is specified for the column. | Task | |
| KOLAP-5928 | Added the SQL command: VERIFY BACKUP. | Task | |
| KOLAP-5930 | Improved performance by distributing queries on replicated tables more evenly. | Task | |
| KOLAP-5945 | Addressed an issue where NULL would be written for the new value instead of the specified expression in a MERGE INTO command when the WHEN NOT MATCHED THEN INSERT clause contained an expression containing multiple columns. | 7.2.3.14 | Bug |
| KOLAP-5951 | Addressed an issue where an INSERT may fail if numerical values using different formats (e.g., some with scientific notation and some without) for values going into the same column were included in the same insert statement. | 7.2.3.14 | Bug |
| KOLAP-5956 | Added support for the chunk-skip index to support UUID and unrestricted string columns. | Task | |
| KOLAP-5957 | Addressed an issue preventing casting from long string types (char128 or larger) to UUID. | Task | |
| KOLAP-5965 | Added a new 'enable_inplace_updates' option to the global config and to /update/records. When 'true' (the default) updates will be done in-place when possible. If the option is set to 'false' then updates will be performed as separate DELETE + INSERT operations. This allows Materialized Views to keep consistent views of the data avoiding leakage by in-place updates. | Task | |
| KOLAP-5976 | Addressed an issue where the error "Index 0 out of bounds for length 0" would sometimes be returned when using the ARRAY_ITEM() function inside a sub-query. | 7.2.3.16 | Bug |
| KOLAP-5981 | Addressed an issue where the EXCLUDE clause was ignored in a window function without an ORDER BY clause. | 7.2.3.17 | Bug |
| KOLAP-5984 | Addressed an issue leading to Postgres Wireline Protocol connections being refused when many requests were received at the same time. | master | Bug |
| KOLAP-5985 | Addressed an issue where attempting to create a Materialized View with interval partitioning would return an error. | 7.2.3.17 | Bug |
| KOLAP-5987 | Addressed an issue where adding a JSON, VECTOR or ARRAY column to a table with a default value would return an error. | 7.2.3.17 | Bug |
| KOLAP-5990 | Added support for anonymous procedural blocks. | Task | |
| KOLAP-5991 | Added support for IN/OUT/INOUT stored procedure parameters. | Task | |
| KOLAP-6003 | Addressed an issue where a Materialized View with a specified EXECUTE AS user would be initially created without that user's permissions. | master | Bug |
| KOLAP-6006 | Addressed an issue where a UDF running as a user with restricted-access to a table, might have the temporary view of the table dropped before the UDF completes. | master | Bug |
| KOLAP-6008 | Addressed an issue causing a "Not all of the non-replicated tables are equated by shard keys" error to be returned for join expressions involving the NULLABLE() function. | 7.2.3.17 | Bug |
| KOLAP-6020 | Improved performance on equality joins on large multi-chunk tables. | Task | |
| KOLAP-6025 | Addressed an issue where the result table of a group-by operation would only have one (potentially very large) chunk. | master | Bug |
| KOLAP-6032 | Addressed an issue where some queries with a LIMIT of 1 could return an erroneous error. | 7.2.3.17 | Bug |
| KOLAP-6038 | Addressed an issue where tDROP TABLE commands were not handled properly within a SQL Procedure. | 7.2.3.17 | Bug |
| KOLAP-6040 | Added support for unrestricted strings in the LIKE and ILIKE functions. | Task | |
| KUI-3053 | Addressed a procedural SQL parsing issue in Workbench SQL/code blocks. | 7.2.3.14 | Bug |
| KUI-3054 | Addressed a table configuration issue in Workbench where clearing vector column size field to empty caused the field to disappear. | 7.2.3.14 | Bug |
| KUI-3061 | Addressed an issue in Reveal where large slice definitions could exceed the request line size limit on some load balancers; slice save and slice designer view now use a POST request. | Task | |
| KUI-3062 | Added support in Reveal for syncing a table to its live database table, automatically adding, updating, and removing columns to match the source instead of requiring manual changes. | Task | |
| KUI-3064 | Added additional per-step information to the GAdmin explain plan from the query history and span metrics tables, including network shuffle, disk I/O, and memory usage. | Task | |
| KUI-3065 | Added additional per-step information to the Workbench explain plan from the query history and span metrics tables, including network shuffle, disk I/O, and memory usage. | Task | |
| KUI-3068 | Added support for anonymous procedural blocks in Workbench, allowing a DO block to run inline without explicitly creating a procedure. | Task | |
| KUI-3069 | Added support for anonymous procedural blocks in GAdmin, allowing a DO block to run inline without explicitly creating a procedure. | Task |
7.2.3.19
- The previous 7.2.3 release was 7.2.3.18.
- It is recommended to use the latest KAgent version (7.2.3.18) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.20
- Apache HTTP Server (httpd) version 2.4.68
- Apache Tomcat version 9.0.120
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KDEVOPS-3098 | Upgraded Apache Tomcat to 9.0.120. | Task | |
| KINFRA-4190 | Added support for on-demand hydration of Parquet files from Iceberg tables. | Task | |
| KINFRA-4254 | Added hints (KI_HINT_MAX_CONCURRENCY(N) and KI_HINT_SCHEDULING_PRIORITY(N)) to allow users to run queries under a lower concurrency/priority than their resource group would otherwise use. | Task | |
| KINFRA-4257 | Addressed an issue with exporting and importing float and double array columns to/from Parquet files. | 7.2.2.23 | Bug |
| KINFRA-4260 | Addressed an issue with persisting subscription requests when the schema id is not provided. | 7.2.3.18 | Bug |
| KINFRA-4261 | Addressed an issue where merging older backup snapshots containing non-schema object files (KiFS, UDFs, etc.) could be lost leading to corrupt backups that could not be fully restored. | 7.2.3.18 | Bug |
| KINFRA-4263 | Addressed an issue where records in a Kafka subscription could be skipped due to the schema changing in the schema registry during processing. | 7.2.3.18 | Bug |
| KINFRA-4264 | Addressed an issue where queries could fail when reading compressed files from a cloud-backed filesystem | 7.2.3.0 | Bug |
| KINFRA-4265 | Addressed an issue where temporary memory used during sorting was not being tracked. | Task | |
| KINFRA-4267 | Addressed an issue where job completion could crash a rank process when finalizing telemetry data. | 7.2.3.18 | Bug |
| KINFRA-4269 | Addressed an issue where Kafka subscriptions to sharded tables could slowly leak memory with each insert. | 7.2.0.1 | Bug |
| KOLAP-5580 | Addressed an issue where some graph queries using IN or OR in the WHERE clause would return errors. | 7.2.3.3, 7.2.3.4 | Bug |
| KOLAP-5784 | Added a new text indexing capability. Uses standard "ALTER TABLE mytable ADD/DROP TEXT INDEX(mycolumn)" syntax. Text indexed columns can be queried and ranked using the new TEXT_MATCH(), TEXT_MATCH_BM25() and TEXT_MATCH_BM25_GLOBAL() functions. Note this functionality deprecates the older text indexing functionality where text search was a property of a column. After upgrading users will need to add in text indexing to their desired columns via the alter table syntax. | Task | |
| KOLAP-5892 | Added support for error_handling modes of Permissive, Skip and Abort in more endpoints and SQL Commands. | 7.2.3.11 | Bug |
| KOLAP-5923 | Added automatic background collection of table and column statistics that are relevant to the SQL Planner. This is currently turned off by default. Enable and configure using the "sql.automatic_stats" and related config settings. | Task | |
| KOLAP-5929 | Addressed an issue where joined deletes and joined updates on replicated tables would result in inconsistent results. These operations will now return an error. | master | Bug |
| KOLAP-5975 | Addressed an issue where queries with scoped hints were being rejected when submitted via the Postgres Wireline Protocol. | 7.2.3.16 | Bug |
| KOLAP-5976 | Addressed an issue where the error "Index 0 out of bounds for length 0" would sometimes be returned when using the ARRAY_ITEM() function inside a sub-query. | 7.2.3.16 | Bug |
| KOLAP-6027 | Added support for incremental refreshing for materialized views with unrestricted strings and other variable-length columns. | master | Bug |
| KOLAP-6043 | Improved performance for copying data from a replicated table to a sharded table. | Task | |
| KOLAP-6051 | Addressed an issue where deeply recursive SQL procedures could lead to a crash. With this change recursive calls are limited to a depth of 64. | 7.2.3.18 | Bug |
| KOLAP-6052 | Addressed an issue where string literal text values were being incorrectly escaped in the return values of SQL procedures. | 7.2.3.18 | Bug |
| KOLAP-6053 | Added support for subqueries in dynamic SQL expressions. | 7.2.3.17 | Bug |
| KOLAP-6054 | Addressed an issue where counts for table statistics were not being referenced correctly in some cases by the SQL planner, resulting in different query plans for nearly identical queries. | 7.2.3.17 | Bug |
| KOLAP-6068 | Addressed an issue resulting in an error "index (1) must be less than size (1)" for some SQL queries containing both a LIMIT of 1 and an IN expression. | 7.2.3.18 | Bug |
| KOLAP-6079 | Added support for more formats for datetime literals, including timezone fields. | Task | |
| KOLAP-6080 | Added a new 'feature.cascade_drop_views' config parameter to restore legacy behavior of dropping dependent views (and SQL procedures) when a table is dropped, rather than the new behavior of invalidating them. | Task | |
| KOLAP-6087 | Addressed an issue where certain queries with derived columns and sort expressions could result in an error indicating that the sort column does not exist. | 7.2.3.19 | Bug |
| KOLAP-6089 | Addressed an issue where the UNIX_TIMESTAMP function would return invalid results for dates past the year 2038 by changing the output to a long instead of an integer. Now UNIX_TIMESTAMP is an alias for the SECS_SINCE_EPOCH function. | Task | |
| KOLAP-6096 | Addressed an issue where an index-out-of-bounds error would be returned when SELECT * EXCLUDE (...) is used over a JOIN ... USING or NATURAL JOIN. | 7.2.3.19 | Bug |
| KUI-3074 | Addressed an issue in GAdmin and Workbench where vector column values would display without square brackets in some places. | 7.2.3.18 | Bug |
| KUI-3076 | Added a treemap visualization to Workbench for exploring table and column usage across storage tiers. | Task | |
| KUI-3077 | Added a treemap visualization to GAdmin for exploring table and column usage across storage tiers. | Task | |
| KUI-3078 | Added a new Reveal capability for copying geographic filter features, which can later be pasted and applied to recreate the filter. | Task |
7.2.3.20
- The previous 7.2.3 release was 7.2.3.19.
- It is recommended to use the latest KAgent version (7.2.3.19) with this release.
- This version includes the following components
- Kinetica JDBC Driver version 7.2.3.24
- Apache HTTP Server (httpd) version 2.4.68
- Apache Tomcat version 9.0.121
| Key | Release Note Description | Affects versions | Issue Type |
|---|---|---|---|
| KDEVOPS-3106 | Upgraded Apache Tomcat to 9.0.121. | Task | |
| KDEVOPS-3107 | Upgraded Python to 3.10.21. | Task | |
| KGEO-1406 | Addressed an issue where the graph server could crash when creating directed graphs using geospatial expressions. | 7.2.3.17, 7.2.3.18, 7.2.3.19 | Bug |
| KINFRA-4274 | Added ki_catalog.ki_internal_stats catalog table to expose various internal values for debugging. | Task | |
| KINFRA-4276 | Addressed potential rank crash when recording tier metrics. | 7.2.3.19 | Bug |
| KINFRA-4277 | Addressed an issue where a crash could occur during cluster shutdown. | 7.2.3.19 | Bug |
| KINFRA-4279 | Improved performance of ALTER TABLE ... SET TIER STRATEGY by apply the tier strategy change in-place. | 7.2.3.19 | Bug |
| KINFRA-4283 | Enhanced the logic of default assigned WAL segment_count to better handle wide tables. | Task | |
| KINFRA-4285 | Addressed an issue where a Kafka message containing a JSON array of records was incorrectly parsed. | 7.2.3.0 | Bug |
| KINFRA-4290 | Added the ability to kill a UDF with /kill/proc during input data population. | Task | |
| KINFRA-4291 | Improved performance of single file S3 deletions by eliminating an unnecessary remote call. | 7.2.3.19 | Bug |
| KINFRA-4292 | Addressed an issue where Avro array and map columns would be decoded incorrectly due to improper escaping of special characters. | 7.2.3.0 | Bug |
| KINFRA-4293 | Addressed an issue where the tier manager could fail to properly evict join stencils when the tier was under high contention. | 7.2.3.19 | Bug |
| KINFRA-4295 | Addressed an issue where removing a host from a cluster could erroneously fail. | 7.2.3.18 | Bug |
| KINFRA-4296 | Addressed an issue where read/write verification of a data sink can lead to a crash. | 7.2.3.19 | Bug |
| KOLAP-5826 | Added support for Unity Catalog for Delta Lake. | Task | |
| KOLAP-5947 | Added a new config parameter: enable_persist_fk_indices (default: false). When enabled, foreign-key join indexes are saved to disk and reused across restarts, speeding up start-up and avoiding unnecessary index rebuilds. | Task | |
| KOLAP-6026 | Enhanced tracing to capture only specific requests. | Task | |
| KOLAP-6041 | Added support for AWS Glue Catalog. | Task | |
| KOLAP-6083 | Added memory tracking and reporting to the chunk skip index. | Task | |
| KOLAP-6113 | Addressed an issue leading to a crash when performing certain semi/anti-join operations on an empty table. | 7.2.3.20 | Bug |
| KOLAP-6123 | Added support for credential vending for AWS Glue Catalog for Iceberg tables. | Task | |
| KOLAP-6134 | Enhanced the filter plan output to include information on chunk skipping. | Task | |
| KOLAP-6137 | Improved performance by supporting chunk skipping using existing partition information. | Task | |
| KOLAP-6148 | Added a new SQL command: SHOW WAL [FOR] <table> to display the status of the WAL. | Task | |
| KOLAP-6157 | Addressed an issue where sorting in descending order could return the results in the wrong order. | 7.2.3.18 | Bug |
| KOLAP-6161 | Addressed an issue leading to a crash in some cases when a request for records was made on an invalidated view or SQL procedure. | 7.2.3.19 | Bug |
| KOLAP-6163 | Addressed an issue where constants specified in LIST partitions were not correctly handling escaped quotes. | 7.2.3.20 | Bug |
| KOLAP-6170 | Added a new config parameter (sql.procedure_return_final_select). When true (the default) the result of the last SELECT statement of a procedure will be returned, even if there are subsequent non-SELECT statements. When false the result of the last statement will be returned. | Task | |
| KOLAP-6172 | Addressed an issue where invalidated SQL Procedures were not being automatically re-validated in certain cases. | 7.2.3.20 | Bug |
| KOLAP-6175 | Addressed an issue leading to a crash when performing a primary key upsert on a table with a geometry column with a geospatial index. | 7.2.3.19 | Bug |
| KOLAP-6179 | Addressed an issue leading to a crash when processing some JSON and ARRAY from STRING conversions and aggregations; | 7.2.3.19 | Bug |
| KUI-2935 | Switched to using the PostgreSQL wireline protocol in Reveal as the default connection to the database, replacing ODBC (API endpoint calls remains unchanged). | Task | |
| KUI-3079 | Added support in Workbench for optional editable workbook sharing. | Task | |
| KUI-3081 | Added support in Workbench for per-column TEXT INDEX tuning. | Task | |
| KUI-3082 | Added support in GAdmin for per-column TEXT INDEX tuning. | Task | |
| KUI-3084 | Added support in Workbench for managing SQL procedures. | Task | |
| KUI-3086 | Improved auto-complete performance/usability in Workbench SQL editors. | Task | |
| KUI-3090 | Added support in GAdmin for per-query tracer instead of using the global logger. | Task |
Comments
0 comments
Article is closed for comments.